Reply to topic

Gizmo fail on Windows 7 X64
Jean Louis-guerin


Joined: 04 Mar 2011
Posts: 3
Reply with quote
I have install Gizmo 277 on a Windows 7 Ultimate X64 downloaded from your site.

Each time I start the system I am getting an error message:
Run DLL: There was a problem starting c:\PROGRAM The specified module could not be found.

I have located the problem to be an entry added in the registry:
HKCU\Software\Microsoft\Windows\CurrentVersion\RUN
Key: GizmoDriveDelegate
Value: RUNDLL32.EXE C:\PROGRAM FILES (X86)\GIZMO\GDRIVE.DLL,Remount_Startup_Images

The value should contains quote something like
RUNDLL32.EXE "C:\PROGRAM FILES (X86)\GIZMO\GDRIVE.DLL,Remount_Startup_Images"

I have tried to remove the key directly with regedit or with msconfig and it works when I reboot the system but unfortunately the next time the key is put back! I have also tried to place the quotes in the key value and again it works the first time but after the value is changed back and quotes are removed.

Any idea how to fix this irritating problem?
Thanks
View user's profileSend private message
problem starting gdrive dll
dani yoda


Joined: 10 Mar 2011
Posts: 4
Reply with quote
once loggin in, i still receive the popup:

problem starting c:\program files\...\gdrive dll
module could not be found

Gizmno was uninstalled, than installed again, then uninstalled again, always rebooted after each step

no entry in startup

how can i remove this RunDLL issue?
View user's profileSend private message
dani yoda


Joined: 10 Mar 2011
Posts: 4
Reply with quote
was able to remove it, with regedit, like here:
http://www.squidoo.com/rundllerror
View user's profileSend private message
Jean Louis-guerin


Joined: 04 Mar 2011
Posts: 3
Reply with quote
dani yoda wrote:
was able to remove it, with regedit, like here:
http://www.squidoo.com/rundllerror

This is the first think I have tried.
Removing or fixing the entry in the registry is easy and it works the next time I start the computer. However at the next rebbot the invalid entry is back again. So it looks like the entry is "regenerated" by Gizmo each time you reboot and therefore fixing it only works one time.

What is strange is that on another system it works correctly without any modification.

What I now suspect is that on the system that fails I do not have the creation of short NTFS file names (8.3) enabled I will do the test and report if this fix the problem.
View user's profileSend private message
Jean Louis-guerin


Joined: 04 Mar 2011
Posts: 3
Reply with quote
I have found a solution Smile But I consider this as a bug in Gizmo Sad !!!

Indeed the problem is related to short 8.3 names.
With the "working system" the entry is
HKCU\Software\Microsoft\Windows\CurrentVersion\RUN
Key: GizmoDriveDelegate
has the following value:
RUNDLL32.EXE C:\PROGRA~2\GIZMO\GDRIVE.DLL,Remount_Startup_Images and works fine.

For some reason on the non working system short file name was not enabled.

FIX - This is a bit difficult to explain but I will try my best:

1) first check that short file name are enabled on the volume that contains the programs. If this is not the case then enable it. The easiest way is to us the following command (in an administrator cmd):
Code:
fsutil 8dot3name set 0

value 0 enable short name creation on all disks or you can use 3 if you want only on system disk.

2) check that program file (x86) directory has a short name:
Code:
cd \
dir .* /x

If you have the problem then no short name should be shown

3) unfortunately it is not possible to generate short name on program files directory as it is used by the system (access denied). therefore you have to restart the system using a boot disk like WinPE or WinRE or something equivalent (in my case dual boot). Then cd to the root directory of your system partition and type the following command:
Code:
fsutil setshortname "program files" PROGRA~1
fsutil setshortname "program files (x86)" PROGRA~2


4) restart your system as usual open a cmd cd to root and type
Code:
cd \
dir *. /x

you should now see something like this
Code:
03/13/2011  10:13 AM    <DIR>          PROGRA~1     Program Files
03/14/2011  10:21 AM    <DIR>          PROGRA~2     Program Files (x86)


5)uninstall gizmo and reinstall gizmo

6) to check that the problem is fixed type msconfig and go to the startup tab. Here you should see a rundll entry for gizmo and check that it uses PROGRA~2

7) now you can reboot your system and everything should now run ok

BUG:
Gizmo should support file system without 8.3 names enabled and therefore should use correctly long names. This means that in that case it should put quotes around the files names:
RUNDLL32.EXE "C:\PROGRAM FILES (X86)\GIZMO\GDRIVE.DLL",Remount_Startup_Images

This fixed my problems and I hope this can help other having the same problem.
Jean
View user's profileSend private message
Logan Mueller
Support

Joined: 16 Nov 2003
Posts: 565
Reply with quote
Hi Jean,

Thanks for looking into this so thoroughly and sharing your findings with everyone. You are correct, this was a bug in v2.7.7 and it has been fixed in the new v2.7.8 release.

_________________
Support is provided as a convenience to our users. We make no guarantees in the timeliness and accuracy in our responses. We reserve the right to refuse service to anyone.
View user's profileSend private messageVisit poster's website
Gizmo fail on Windows 7 X64
All times are GMT - 8 Hours  
Page 1 of 1  

  
  

 Reply to topic