Reply to topic

Gizmo drive bug (dishonoured setting?)
Gizmo User


Joined: 25 Feb 2012
Posts: 3
Reply with quote
Windows 7 Ultimate x64 SP1
Gizmo Drive 2.7.9
Start Gizmo manager and set up two virtual drives.
Add a shortcut for both drives with these options being the same:
- Image: <leave empty>
- Check "Unmount existing images tied to this drive letter"
- Afterwards: select "Do nothing"
- Run: <leave empty>
- Check "Remount image when Windows starts"
- Check "Mount image as read-only"
- Uncheck "Show the Image Mounting window before mounting"
- If already mounted: select "Unmount the image silently"

and these being different:
- Drive letter (1): W
- Drive letter (2): X

Save and close manager.
Bring up the manager and click on virtual drive #1.
You get an error: System based error has occurred. OPEN FILE The filename, directory name, or volume label syntax is incorrect.
While it is accurate, the right error message to be show would be: "No image selected."

Now go back to the manager and change this for both drives:
- Check "Show the Image Mounting window before mounting"

Save and close manager.
Bring up the manager and click on virtual drive #1.
The mount image dialog is shown.
Select an image and mount it. (Do not change any other settings.)
Wait a few moments and make sure it was mounted correctly.
Now comes our bug.
Bring up the manager and click on virtual drive #1.
The mount image dialog is shown.
Notice anything?
The currently mounted image was not unmounted as instructed using the If already mounted: "Unmount the image silently" setting and, in addition, the drive letter has been changed to 'Y'.

There are number of bug here, I hope you can fix all them soon.
Thank you.

PS. The second drive (letter X) may not be needed for this test to produce the same results, but I included it anyway because that's my setup here.
View user's profileSend private message
Gizmo drive bug (dishonoured setting?)
All times are GMT - 8 Hours  
Page 1 of 1  

  
  

 Reply to topic