Reply to topic

NTFS share permissions on VHD gone sometimes after reboot
Sue Morton


Joined: 30 Dec 2009
Posts: 11
Reply with quote
First off I just want to say Thank You for Gizmo Central! I am new user only of some days and Gizmo Drive was a great answer to a sticky problem. I searched the 'net for many hours, looking for ways to solve my issue when I stumbled upon Gizmo and that was what I needed. Again, thank you!

I am mounting a VHD using Gizmo on an XP Pro SP2 32-bit system. This is not a bootable VHD, it's a 60G 'plain' virtual disk that was created by Win7 Pro 32-bit, initialized and formatted with NTFS and copied to my XP machine. In almost every respect it is working perfectly, Gizmo remounts it on a reboot and all has been well so far.

Using NTFS share permissions I shared this VHD virtual drive at the root, so it would be seen as any drive on the LAN. However, after a reboot when Gizmo remounts the VHD, the share is often (but not always) gone.

To correct the issue I did try adding the share, confirming it worked, then unmounting/remounting the VHD. This did not correct the issue, the share is still disappearing frequently.

Is there anything else I should do, or do differently, to cause the share permissions to 'stick'? Thanks in advance for any help.

Kind regards,
--Sue Morton
View user's profileSend private message
Lawrence Chim


Joined: 29 Dec 2009
Posts: 2
Reply with quote
I think your issue may occur when Gizmo is not initialized when the Server service initializes. The Server service creates file shares, i.e. Server service starts before Gizmo does. Because the virtual disk is not available, the Server service cannot create file shares for the virtual disks until the Gizmo is initialized.

You may need to modify the Registry to create the dependency, but you have to find out the service name pertaining to Gizmo.
View user's profileSend private message
Sue Morton


Joined: 30 Dec 2009
Posts: 11
Reply with quote
Thank you for your reply, your suggestion makes good sense to me, I had not thought of that dependency (I should have!). Thank you, I will check on that.

Kind regards,
--Sue Morton
View user's profileSend private message
Sue Morton


Joined: 30 Dec 2009
Posts: 11
Reply with quote
I added lanmanserver as a dependency for both the Gizmo Central service and GizmoDrv service (the drive mounting application is the only one I've installed so far).

I verified after reboot that both Gizmo services waited for Server to start and that was indeed the case. However, after Gizmo launched and my VHD was mounted, again it no longer had the share.

As a test, I added my share again, disabled caching, and manually dismounted the drive from Gizmo. I rebooted, once everything was up I returned to Gizmo and re-mounted the drive. The share is gone.

Thanks for idea, I thought it stood a very good chance of solving the problem, but there must be a little more to this.

Kind regards,
--Sue Morton
View user's profileSend private message
Sue Morton


Joined: 30 Dec 2009
Posts: 11
Reply with quote
I now have a workaround (maybe the only way?) to keep my VHD as a share on the network.

I created a batch file to (re)create the share, disable offline file caching, and set full NTFS permissions for my userid.

Right now I'm running the batch file manually, but I'd like it to run automatically after Gizmo mounts the VHD (autoplay?). If anyone knows how to do this, please let me know, TIA!

Here's my batch file. I located the program RMTSHARE.EXE, originally from the Windows NT 4.0 Resource Kit and since then Microsoft released it into public domain. I located a few different versions of this program, all but one didn't work. I'm sorry, I can't tell you now where to get the one I'm using... if you look around and find them, the one I'm using successfully has a last modified date of 2/19/1999 and size is 13,072 bytes.

This program version is working fine for me on XP Pro SP3 32-bit. (From what I've read, this version will also work on Win2k and Server 2003.)

Code:
@echo off
net share my-share-name /delete
net share my-share-name=x:\ /unlimited /remark:"" /cache:none

c:
cd "\Program Files\rmtshare\"
RMTSHARE \\machine-name\my-share-name /grant domain\userid:f
RMTSHARE \\machine-name\my-share-name /remove everyone
RMTSHARE \\machine-name\my-share-name /unlimited


See RMTSHARE /? for syntax and other parameters.

If you're not a domain user as I am, you can leave off the "domain\" part, it will look for the userid as a local machine account.

Be sure to "quote" any machine names, share names, and paths that contain spaces.

This is what the above batch file does:

    1. Remove the share-name if already known
    2. Create the share at the root of drive x:, with unlimited user connections, no comment info, and offline file caching off
    3. Grant FULL permissions to my userid on the domain
    4. Revoke "everyone" from access (default when share is created, "everyone" is automatically given read access unless otherwise configured in registry)
    5. Set unlimited user connections (probably redundant with #2 but since everything is working now I haven't bothered to test if this is necessary!)


This works for batch creation of any share and/or NTFS permissions on XP Pro, not just on a VHD. Dunno about XP Home, I don't have any of those...

Right now I'm running the batch file manually after Gizmo mounts the VHD. I'd like to run it automatically after mount but don't have the time to invest looking into it at the moment. If anyone knows how to do that, please let me know, would be very much appreciated. Otherwise, when I can next spend the time, if I find a way to autorun (using autoplay, maybe?) I'll post back then.

Kind regards,
Sue Morton
View user's profileSend private message
Logan Mueller
Support

Joined: 16 Nov 2003
Posts: 565
Reply with quote
Hi Sue,

Thank you for posting this info in such great detail.

Judging from your other post, it seems you have found a solution: mounting the image silently using piped options in the batch file used with RMTSHARE, and creating shortcut to the batch file in your Windows Startup folder instead of using Gizmo's remount option.

It would probably be good for Gizmo to save and restore the permission on the virtual drives in a future version.

_________________
Support is provided as a convenience to our users. We make no guarantees in the timeliness and accuracy in our responses. We reserve the right to refuse service to anyone.
View user's profileSend private messageVisit poster's website
Sue Morton


Joined: 30 Dec 2009
Posts: 11
Reply with quote
Thank you Smile

Kind regards,
--Sue Morton
View user's profileSend private message
NTFS share permissions on VHD gone sometimes after reboot
All times are GMT - 8 Hours  
Page 1 of 1  

  
  

 Reply to topic